A Button With Events & a Link

Issues related to hyperlinks and web site navigation.
Forum rules
PLEASE READ THE FORUM RULES BEFORE YOU POST:
viewtopic.php?f=12&t=1901

MUST READ:
http://www.wysiwygwebbuilder.com/links.html
Post Reply
faithfulfox
 
 
Posts: 4
Joined: Sat Jul 06, 2019 7:57 pm

A Button With Events & a Link

Post by faithfulfox » Sat Jul 06, 2019 8:29 pm

I was working in V14 and discovered Version 15 is available.

I have a button created from a rectangle shape. The page is a lightbox. When people click "continue" on the page I want it to open an external page in a new tab that allows them to place an order (on a site I do not control).

Simultaneously, I want to change the message on the lightbox page so it asks them if they placed the order and give a new button to click to continue. So when they come back to my page after ordering, they will see the new message.

I accomplish this with events to show a second layer and hide some text from the original page. Then I use a link under the links tab to do the external page opening.

All this worked fine in Version 14. But when I switched to Version 15, added some inline frames. After that the events part works fine but it will not open the external link. (just to check I removed the inline frames but did not help)

If I use the "link" command in the "Events" tab it will open the page but it remains in the lightbox. The "target" parameter does not allow an entry to send it to a new page.

Is this an issue with V15 or is there something I can do to fix it? Any work arounds?

( I have 4 pages like this. Only the 1 I modified with V15 is not working as I intended.)
Last edited by faithfulfox on Sat Jul 06, 2019 9:04 pm, edited 1 time in total.

User avatar
Pablo
 
Posts: 17608
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: A Button With Events & a Link

Post by Pablo » Sat Jul 06, 2019 8:47 pm

To be able to help you I need to see what you have done.
Can you please share a demo project?
Related FAQ:
http://www.wysiwygwebbuilder.com/forum/ ... 10&t=82134
If I use the "link" command in the "Events" tab it will open the page but it remains in the lightbox.
Correct. This function uses Javascript: window.location.href, so this is standard browser behavior. It does not work different than in WB14.

The 'target' property is to select an object for event actions, this is not relevant for links.

faithfulfox
 
 
Posts: 4
Joined: Sat Jul 06, 2019 7:57 pm

Re: A Button With Events & a Link

Post by faithfulfox » Sat Jul 06, 2019 10:09 pm

After hours of troubleshooting this, this is my conclusion:
The Event code that has been created by the V14 will allow the events + the link actions.
If I modify the event so that V15 has to provide new code, the link will not work when there are events.

Here is an early version: http://powerlifepro.info/machines.html

Click on a machine.. That brings up a layer. Click on "Own It" and it will bring up the lightbox.
Click on Continue and it should open an external site in a new window. At the same time it should modify the lightbox which will then be underneath the new window.

On the JRII is where I did the experimenting. The other 3 work as I intended because it is V14 code) but do not have the inline frame I would like to use.

User avatar
Pablo
 
Posts: 17608
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: A Button With Events & a Link

Post by Pablo » Sun Jul 07, 2019 6:44 am

I do not think this behavior has changed in WB15. Maybe you are using different settings?

Can you share a demo project created in WbB4 so I can see what you have done?

faithfulfox
 
 
Posts: 4
Joined: Sat Jul 06, 2019 7:57 pm

Re: A Button With Events & a Link

Post by faithfulfox » Sun Jul 07, 2019 12:35 pm

No. Once it is opened or modified with V15 it can no longer be opened with V14. The project you are looking at is coded with V14 except the page I tested & tried to update.

Since there are 4 identical pages except for the link to the external page, it gives a good control.
I duplicated one of the pages to play with it.
Adding the inline frame did not affect it.
But if I tried to hide the inline frame when showing the layer 1, it made the link stop working.
So, I tried to see if other modifications to the "Events" function had the same affect. Anytime I modified it so that V15 would have to revise the code the link would no longer work.

(Note: Clicking on the JR Machine on the sample page is V15 revision. Clicking on anyu other machine is V14 coded.)

The basic question is this: is it normally possible to Set the behavior of the page with Event Tab and at the same time use the Links tabe to connect to an external page? Not using the "link" command on the Events Tab

User avatar
Pablo
 
Posts: 17608
Joined: Tue Mar 28, 2006 12:00 pm
Location: Europe
Contact:

Re: A Button With Events & a Link

Post by Pablo » Sun Jul 07, 2019 12:43 pm

The basic question is this: is it normally possible to Set the behavior of the page with Event Tab and at the same time use the Links tabe to connect to an external page? Not using the "link" command on the Events Tab
Yes, this is normal behavior and it is explained here:
http://www.wysiwygwebbuilder.com/forum/ ... 10&t=37833

Note, that this behavior has not changed in WB15

faithfulfox
 
 
Posts: 4
Joined: Sat Jul 06, 2019 7:57 pm

Re: A Button With Events & a Link

Post by faithfulfox » Sun Jul 07, 2019 7:28 pm

I believe that Java Script entry in the Events section solved the problem.
Awesome. thanks very much.

Post Reply